Thread: Issue with climate control mode

Results 1 to 5 of 5
  1. #1 Issue with climate control mode 
    GT Level Member
    Join Date
    Mar 2018
    Location
    NY
    Posts
    159
    Thanks (Received)
    2
    Likes (Received)
    3
    Dislikes (Received)
    0
    Chats
    0
    Took the Grand Prix out of winter storage this past week & so far so good, but I did run into a little hiccup with the climate control system. I have the basic single zone 3-knob setup. What happened is its stuck on the bi-level setting (blowing from dash & floor) which is where it was when I put it away for the winter. There is no vacuum tension trying to change modes. It just turns without feeling much if any resistance, but doesn't feel like the plastic knob itself broken (went through a lot of those years ago with my old grand am). I also thought it would default to defrost mode if there was a vacuum problem. Is there anything common that would cause this to happen before I start tearing everything apart?
    Reply With Quote  
     

  2. #2 Re: Issue with climate control mode 
    GrandPrix Junkie
    Join Date
    Oct 2009
    Location
    St. Louis
    Posts
    4,607
    Thanks (Received)
    17
    Likes (Received)
    67
    Dislikes (Received)
    0
    Chats
    0
    Dumb question but did you pull the knob and use one of the other ones to try and turn it? I've noticed that 3-zone control on mine would get harder to turn when it sat and ended up with a cracked knob that would move but not turn the metal post in the HVAC unit all the way.

    Pull the knob and see if you can move the post with pliers and get it to change direction. If that doesn't work then I'd think either a line is messed up or the HVAC unit is leaking vac.

    IMHO if it doesn't default to defrost then I wouldn't think it's a vac problem as IIRC a loss of vacuum would indeed put it on defrost.
    Reply With Quote  
     

  3. #3 Re: Issue with climate control mode 
    GT Level Member
    Join Date
    Mar 2018
    Location
    NY
    Posts
    159
    Thanks (Received)
    2
    Likes (Received)
    3
    Dislikes (Received)
    0
    Chats
    0
    I got my answer. I pulled the knob and you are correct, it was cracked. Not big enough to fall off on its own, but small enough to still hold the metal ring and flex when I turned it instead of turning the stalk on the switch. I'll try that dorman kit that has the three different ones first...its cheap enough. I guess I was dumb enough not to think of that in the first place lol
    Reply With Quote  
     

  4. #4 Re: Issue with climate control mode 
    GrandPrix Junkie
    Join Date
    Oct 2009
    Location
    St. Louis
    Posts
    4,607
    Thanks (Received)
    17
    Likes (Received)
    67
    Dislikes (Received)
    0
    Chats
    0
    Glad you found it! Not dumb, I've jumped to conclusions before and have been bit with the simple answer. 20 yr old plastic knobs aren't what they used to be, lol..
    Reply With Quote  
     

  5. #5 Re: Issue with climate control mode 
    GT Level Member
    Join Date
    Mar 2018
    Location
    NY
    Posts
    159
    Thanks (Received)
    2
    Likes (Received)
    3
    Dislikes (Received)
    0
    Chats
    0
    No these 20+ year old knobs aren't lol. I guess I was assuming it would have just fallen off into my hand. That dorman kit worked... it has 3 different knobs, but the one matched up & did the trick
    Reply With Quote  
     

Similar Threads

  1. Climate control issue...Please Help
    By mygirlfriendsgp in forum General Tech Discussion
    Replies: 5
    Last Post: 02-05-2013, 12:11 PM
  2. Climate control issue
    By kingjohn1027 in forum 3.8L V6 Supercharged (L67)(L32)
    Replies: 4
    Last Post: 04-12-2012, 09:25 AM
  3. Climate Control Issue, please help!
    By heathersmanforlife in forum General Tech Discussion
    Replies: 4
    Last Post: 06-04-2011, 01:10 PM
  4. Digital Dual Climate Control Mode Problem
    By brandonl2000 in forum General Tech Discussion
    Replies: 2
    Last Post: 01-23-2011, 12:51 PM
  5. Climate Control Issue - Help!
    By sb7605 in forum General Tech Discussion
    Replies: 1
    Last Post: 12-17-2009, 09:50 AM
Tags for this Thread

View Tag Cloud

Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •