Thread: Voltage Drop and Lights Dim when Coming to a Stop

Results 1 to 6 of 6
  1. #1 Voltage Drop and Lights Dim when Coming to a Stop 
    GTP Level Member CHI2000GTP's Avatar
    Join Date
    Dec 2015
    Location
    Chicago, IL
    Posts
    740
    Thanks (Received)
    4
    Likes (Received)
    16
    Dislikes (Received)
    0
    Chats
    1286
    Looking for some tips into what could be causing this ongoing issue that I'm experiencing in my 2000 Turbo Prix. I have a previous post on here form a few days ago where I'm experiencing ignition issues. That issue is now fixed and the car is driving but maybe the two issues are related?


    Whenever I'm coming to a stop, whether pressing on the brake pedal or just coasting to a stop, my voltage drops like a rock. At idle is stays constant at 14.3 or higher. When driving it's around 14.2v or higher. When coming to a stop however, the voltage drops to as low as 9.8v. I have a quick, 20 second video of it happening below. Watch the Aeroforce in the top right corner. Numbers jump from 14.2 > 10.8 > 13.5 > 14.1 > 11.1 > 13.7 > 11.2 > 14.1 ...etc


    Things I've done already:
    Scrubbed, sanded, scrapped all grounds. EXCEPT for the under carpet grounds in the cabin.
    Replaced IAC sensor with brand new AcDelco sensor
    Cleaned MAF sensor


    VIDEO:

    Voltage Drop. - YouTube
    2000 GTP 4DR - Stock
    243,000 miles
    CHICAGO, IL
    My Car: http://www.grandprixforums.com/members-rides/103740-lukes-gtp.html#post1443981
    Reply With Quote  
     

  2. Advertisement




  3. #2 Re: Voltage Drop and Lights Dim when Coming to a Stop 
    GrandPrix Junkie
    Join Date
    Oct 2009
    Location
    St. Louis
    Posts
    4,133
    Thanks (Received)
    8
    Likes (Received)
    15
    Dislikes (Received)
    0
    Chats
    0
    Have you had the alt checked? Wonder if the voltage reg. is on its way out.
    Reply With Quote  
     

  4. Likes Cerberus liked this post
  5. #3 Re: Voltage Drop and Lights Dim when Coming to a Stop 
    GTX Level Member bandook's Avatar
    Join Date
    Apr 2015
    Location
    Columbus, OH
    Posts
    1,225
    Thanks (Received)
    0
    Likes (Received)
    1
    Dislikes (Received)
    0
    Chats
    12
    I would stop in AutoZone or your preferred shop and have your battery and alternator tested.
    Top Swapped 01 Imp.
    SD Headers, 3.25, self ported everything, E85
    Reply With Quote  
     

  6. #4 Re: Voltage Drop and Lights Dim when Coming to a Stop 
    GrandPrix Junkie ItHurtz's Avatar
    Join Date
    Feb 2011
    Location
    Antioch, IL
    Posts
    3,370
    Thanks (Received)
    3
    Likes (Received)
    7
    Dislikes (Received)
    2
    Chats
    124167
    Alt is 5 years old. Have you tried taking the zzp booster off?
    2000 GTPT Sold-brandonhall10 built trans
    2009 Challenger SRT8
    http://www.grandprixforums.net/threa...uestion.....no
    Expert at being gay.
    Reply With Quote  
     

  7. #5 Re: Voltage Drop and Lights Dim when Coming to a Stop 
    GTP Level Member CHI2000GTP's Avatar
    Join Date
    Dec 2015
    Location
    Chicago, IL
    Posts
    740
    Thanks (Received)
    4
    Likes (Received)
    16
    Dislikes (Received)
    0
    Chats
    1286
    Yesterday I put in the spare new battery I have, made sure it was 100% charged. Also put in a nice new stud for the positive terminal.

    No Change.

    Booster is next.
    2000 GTP 4DR - Stock
    243,000 miles
    CHICAGO, IL
    My Car: http://www.grandprixforums.com/members-rides/103740-lukes-gtp.html#post1443981
    Reply With Quote  
     

  8. #6 Re: Voltage Drop and Lights Dim when Coming to a Stop 
    GTP Level Member CHI2000GTP's Avatar
    Join Date
    Dec 2015
    Location
    Chicago, IL
    Posts
    740
    Thanks (Received)
    4
    Likes (Received)
    16
    Dislikes (Received)
    0
    Chats
    1286
    Removed ZZP Voltage Booster - No Change


    Next up is an alternator swap, and going to go ahead and replace ignition switch/harness.

    Also, I've done some reading and it appears that a bad brake booster could be causing this. Doesn't look like a fun job.
    2000 GTP 4DR - Stock
    243,000 miles
    CHICAGO, IL
    My Car: http://www.grandprixforums.com/members-rides/103740-lukes-gtp.html#post1443981
    Reply With Quote  
     

  9. Advertisement




Similar Threads

  1. break lights not coming on till I make complete stop
    By kristine in forum General Grand Prix Discussion
    Replies: 1
    Last Post: 04-11-2015, 03:03 PM
  2. Why does my voltage drop when I got WOT
    By acidcrashdburnd in forum 3.8L V6 Supercharged (L67)(L32)
    Replies: 8
    Last Post: 06-13-2013, 09:12 PM
  3. shudder and voltage drop
    By mofford12 in forum 3.8L V6 Naturally Aspirated (L36)(L26)
    Replies: 1
    Last Post: 02-19-2013, 01:24 PM
  4. ABS ingauging when coming to normal stop - no lights on
    By albow77 in forum Brakes/Suspension/Chassis
    Replies: 14
    Last Post: 01-28-2012, 07:33 PM
  5. Voltage drop from alternator
    By NyteSniper in forum General Tech Discussion
    Replies: 14
    Last Post: 06-12-2011, 06:26 AM
Tags for this Thread

View Tag Cloud

Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •