Thread: 2004 Impala Transmission Clunk in reverse

Results 1 to 2 of 2
  1. #1 2004 Impala Transmission Clunk in reverse 
    SE Level Member
    Join Date
    May 2020
    Location
    Pennsylvania
    Posts
    1
    Thanks (Received)
    0
    Likes (Received)
    0
    Dislikes (Received)
    0
    Chats
    0
    Good evening everyone. I am hoping someone can help. I recently changed my flex plate by dropping the transmission. I put it back together and it started nicely but now it has a loud clunk in the transmission. I feel it on the housing about 6 inches in on the housing. This is a nw noise. Fluid is full, I replaced the mounts while I had the cradle down, and I double checked the cradle bolts and mount bolts. Everything seems installed properly. I removed the half-shaft and reinstalled in because I thought it was not seated properly but it was. I am at a loss on this one. I am not sure why it's clunking. Both O2 sensors are throwing codes too but I think that's a sensor I forgot to plug back in. Any thoughts or ideas?
    I appreciate your insights.
    Reply With Quote  
     

  2. Advertisement




  3. #2 Re: 2004 Impala Transmission Clunk in reverse 
    GrandPrix Junkie
    Join Date
    Oct 2009
    Location
    St. Louis
    Posts
    4,293
    Thanks (Received)
    10
    Likes (Received)
    35
    Dislikes (Received)
    0
    Chats
    0
    Check the flexplate bolts as they may be loose.
    Reply With Quote  
     

  4. Advertisement




Similar Threads

  1. transmission clunk
    By Grimsin in forum 1997-2007 4 speed Automatic (4T65E) (4T65E-HD)
    Replies: 10
    Last Post: 03-01-2014, 05:22 PM
  2. Loud clunk noise shifting from neutral to reverse?
    By CyxRyan in forum General Grand Prix Discussion
    Replies: 12
    Last Post: 04-14-2013, 06:52 PM
  3. Clunk or grinding sound when shift into reverse
    By Coldwaves in forum 1997-2007 4 speed Automatic (4T65E) (4T65E-HD)
    Replies: 20
    Last Post: 01-03-2013, 11:50 AM
  4. clunk going into reverse????
    By vader99 in forum General Tech Discussion
    Replies: 16
    Last Post: 01-20-2010, 06:44 PM
  5. Clunk from diff going into reverse
    By TZFBird in forum 1997-2007 4 speed Automatic (4T65E) (4T65E-HD)
    Replies: 4
    Last Post: 05-18-2009, 10:02 PM
Tags for this Thread

View Tag Cloud

Bookmarks
Bookmarks
Posting Permissions
  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •